読者です 読者をやめる 読者になる 読者になる

Sublime TextでDartを書く環境

今は公式プラグイン出てるので楽。

Dart News & Updates: Using Dart with Sublime Text

Dart SDKをダウンロードしてbin/にパスを通しておく。homebrewでインストールすればいい。パスがエディタからどうしても確認できない場合はターミナルで

PATH=./dart-sdk/bin:$PATH open -a /Applications/Sublime\ Text\ 2.app

とかすれば確認自体はできると思う。

プラグイン導入は簡単で、普通にSublime Text2のパッケージインストールからDartプラグインがインストールできる

インストールしたらhoge.dart作成してファイルタイプがDARTになってる。SyntaxにDartが追加されてる。Build SystemにDartが追加されてる。

で開いてるファイルでdart2js、hoge.dart.jsにコンパイルする。

Dartのまま実行するにはDart Runコマンド呼べばいい。

main,class,import,library,methodあたりを自動で補完してスニペット展開してくれる。

pub install,update コマンドも実行できる。